re = /^Parameter #\d+ \[ <(?:optional|required)> ([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?:\\[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*)*)(?: or NULL)? \$[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*(?: = NULL)? \]$/m
str = 'Parameter #1 [ <optional> Namespaced\\ClassName or NULL $className = NULL ]
Parameter #1 [ <required> Namespaced\\ClassName $className ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end