package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)a=\d{3,4}$`)
var str = `http://www.test.com/test/test-test-test/?a=12
http://www.test.com/test-test/news/?a=734
http://www.test.com/test/?a=0987
http://www.test.com/test/test-test-test/?a=90235`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}