re = /a=\d{3,4}$/mi
str = 'http://www.test.com/test/test-test-test/?a=12
http://www.test.com/test-test/news/?a=734
http://www.test.com/test/?a=0987
http://www.test.com/test/test-test-test/?a=90235'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end