$re = '/^(?:(\$|US[D$]?|US Dollars?)\s?([0-9.,]+)|((?2))\s?((?1)))$/mi';
$str = '22 USD
22usd
us 8
$10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);