import re
regex = re.compile(r"^(?:(\$|US[D$]?|US Dollars?)\s?([0-9.,]+)|((?2))\s?((?1)))$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("22 USD\n"
"22usd\n"
"us 8\n"
"$10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")