import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*(?:(?:\\*|[0-9]+)\\/0*(?:[0-4]))(?:\\s+\\*){4}";
final String string = "2,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0\n\n"
+ "5,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0\n\n\n"
+ "200,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0\n\n\n"
+ "27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0\n\n"
+ "*/16 * * * * /bin/echo 0\n\n"
+ "*/13 * * * * /bin/echo 0\n\n"
+ "*/4 * * * * /bin/echo 0\n\n"
+ "*/2 * * * * /bin/echo 0\n\n"
+ "*/3 * * * * /bin/echo 0\n\n\n"
+ "110,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}