re = /^\h*(?:(?:\*|[0-9]+)\/0*(?:[0-4]))(?:\s+\*){4}/m
str = '2,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
5,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
200,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
*/16 * * * * /bin/echo 0
*/13 * * * * /bin/echo 0
*/4 * * * * /bin/echo 0
*/2 * * * * /bin/echo 0
*/3 * * * * /bin/echo 0
110,5,8,27,30,36,12,15,18,21,24,39,42 * * * * /bin/echo 0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end