#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[(!P]|G..$|]..\||[^?]P$"
Local $sString = "PPCG" & @CRLF & _
"^P" & @CRLF & _
"^[P^]P" & @CRLF & _
"[^?][PG]$" & @CRLF & _
"(?<!\\..)(?!]).$" & @CRLF & _
"^[\w^]*$|!|]P|G]\$$" & @CRLF & _
"!|[^?]P(CG|G..)?$" & @CRLF & _
"[^])]\$|^\^?P|P.\].$" & @CRLF & _
"([.$?]|G\])\$$|^\^?P|\]P$" & @CRLF & _
"([P.$?]\$|[]^]P|G\]\$|CG)$" & @CRLF & _
"!|((G.|P|\.)\$|[^?]P|CG)$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[PPCG]" & @CRLF & _
"^[P\^]" & @CRLF & _
"[^\]]$" & @CRLF & _
"^\^?P" & @CRLF & _
"[^?][PG]$|<|PG" & @CRLF & _
"^[^\\|]*(\\\\)+[^\\|]*[^\]]$" & @CRLF & _
"^(.{,4}|.{9}|.{16,19}|.{5}P)$" & @CRLF & _
"^[^?]*[PG]$|[?$].*\$$" & @CRLF & _
"^[^[]P|]P|(G]|[.])\$$" & @CRLF & _
"\..$|!|\|G|^[\^P]P|P\^|G.\$$" & @CRLF & _
"...\^.P|^!|G]\$$|w|<!|^\^?P"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")