import re
regex = re.compile(r"^[(!P]|G..$|]..\||[^?]P$", flags=re.MULTILINE)
test_str = ("PPCG\n"
"^P\n"
"^[P^]P\n"
"[^?][PG]$\n"
"(?<!\\\\..)(?!]).$\n"
"^[\\w^]*$|!|]P|G]\\$$\n"
"!|[^?]P(CG|G..)?$\n"
"[^])]\\$|^\\^?P|P.\\].$\n"
"([.$?]|G\\])\\$$|^\\^?P|\\]P$\n"
"([P.$?]\\$|[]^]P|G\\]\\$|CG)$\n"
"!|((G.|P|\\.)\\$|[^?]P|CG)$\n\n\n"
"[PPCG]\n"
"^[P\\^]\n"
"[^\\]]$\n"
"^\\^?P\n"
"[^?][PG]$|<|PG\n"
"^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$\n"
"^(.{,4}|.{9}|.{16,19}|.{5}P)$\n"
"^[^?]*[PG]$|[?$].*\\$$\n"
"^[^[]P|]P|(G]|[.])\\$$\n"
"\\..$|!|\\|G|^[\\^P]P|P\\^|G.\\$$\n"
"...\\^.P|^!|G]\\$$|w|<!|^\\^?P")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")