import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<SyslogPri><\\d+>)(?<SyslogDate>[A-Z][a-z]+\\s+\\d+\\s\\d+:\\d+:\\d+)\\s(?<SyslogHost>.*)\\s(?<process>.*):\\s(?<SyslogMessage>.*)$";
final String string = "<165>Dec 16 10:29:59 192.168.99.100 httpd[10583]: site1.example.org 10.4.5.6 - - [16/Dec/2014:10:29:59 -0800] \"GET /rest/somepath/12345\" HTTP/1.1\" 200 105066 \"-\" \"-\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}