const regex = /^(?<SyslogPri><\d+>)(?<SyslogDate>[A-Z][a-z]+\s+\d+\s\d+:\d+:\d+)\s(?<SyslogHost>.*)\s(?<process>.*):\s(?<SyslogMessage>.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<SyslogPri><\\d+>)(?<SyslogDate>[A-Z][a-z]+\\s+\\d+\\s\\d+:\\d+:\\d+)\\s(?<SyslogHost>.*)\\s(?<process>.*):\\s(?<SyslogMessage>.*)$', '')
const str = `<165>Dec 16 10:29:59 192.168.99.100 httpd[10583]: site1.example.org 10.4.5.6 - - [16/Dec/2014:10:29:59 -0800] "GET /rest/somepath/12345" HTTP/1.1" 200 105066 "-" "-"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}