# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img.*?src=")([^"]*?\\/)([^\\/]*\.[^"]+)/\1\3/g;t' <<< "<img rel=\"450x450\" alt=\"15517527191 107d8f145c Z\" title=\"15517527191 107d8f145c Z\" src=\"/system/images/W1siZiIsIjIwMTQvMTAvMTcvMTBfMzRfMDJfNjU0XzE1NTE3NTI3MTkxXzEwN2Q4ZjE0NWNfei5qcGciXSxbInAiLCJ0aHVtYiIsIjQ1MHg0NTA%2BIl1d/15517527191_107d8f145c_z.jpg\" height=\"216\" width=\"450\" />
"