$re = '/(<img.*?src=")([^"]*?\/)([^\/]*\.[^"]+)/';
$str = '<img rel="450x450" alt="15517527191 107d8f145c Z" title="15517527191 107d8f145c Z" src="/system/images/W1siZiIsIjIwMTQvMTAvMTcvMTBfMzRfMDJfNjU0XzE1NTE3NTI3MTkxXzEwN2Q4ZjE0NWNfei5qcGciXSxbInAiLCJ0aHVtYiIsIjQ1MHg0NTA%2BIl1d/15517527191_107d8f145c_z.jpg" height="216" width="450" />
';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;