import re
regex = re.compile(r"\b[1-9](?:,?\d){7}\b", flags=re.MULTILINE)
test_str = ("From RE: Markitwire: 120432889: Mx: 24,693,059 i need to get 24693059\n\n"
"From Automatic reply: Auftrag zur Übertragung IRD Ref-Nr. MMX_23497152 need to get 23497152\n\n"
"From FW: CGMSE 2019-2X A1AN XS2022418672 Contract 24663537 need to get 24663537\n"
"From RE: BBVA-MAD MMX_24644644 + MMX_24644645 need to get 24644644, 24644645\n\n"
"TGF00023242526")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")