$re = '/(<(.*?\:)?(.*?)>)/mi';
$str = '/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/';
$subst = "{\3}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;