import Foundation
let pattern = #"(<(.*?\:)?(.*?)>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
/<string:name>/<path:id>/
/<name>/<path:id>/ # <--- Why this is not matching /{name}/{id}/
/<string:name>/<id>/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{\3}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)