package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\.]*`)
var str = `a1-a2.b1-b2-b3.c1-c2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}