$re = '/[^\.]*/';
$str = 'a1-a2.b1-b2-b3.c1-c2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);