const regex = /[\s\n]*data-dcm-click-tracker[=|\s]([\\'"a-zA-Z0-9-%]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\n]*data-dcm-click-tracker[=|\\s]([\\\\\'"a-zA-Z0-9-%]*)', 'g')
const str = `data-dcm-click-tracker="sdfsdf"
sdfs
data-dcm-click-tracker='sdfsdf'
sdfs
data-dcm-click-tracker=\\'sdfsdf\\'
data-dcm-click-tracker=\\"sdfsdf\\"
data-dcm-click-tracker=sdfsdfcc
data-dcm-click-tracker=df
data-dcm-click-tracker='%ZZDCLICK%' xcxcx
sdfsdfdf data-dcm-click-tracker `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}