import re
regex = re.compile(r"^(?=.{10}(.*))[A-Za-z]+:[0-9]+(?=\h*\1$)", flags=re.MULTILINE)
test_str = ("A:12345678\n"
"A:123456789\n"
"FOO:567890s123\n"
"LOREM:42 ipsum")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")