#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(\s*)(.*?)(?=Foobar)"
Local $sString = "Lorem Ipsum Foobar the summer.." & @CRLF & _
"" & @CRLF & _
" Lorem Ipsum Foobar the summer.."
Local $sSubst = "$1$2\r$1\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)