using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*)(.*?)(?=Foobar)";
string substitution = @"$1$2\r$1\t";
string input = @"Lorem Ipsum Foobar the summer..
Lorem Ipsum Foobar the summer..";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}