using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(\w+)$";
string substitution = @"\2 \1";
string input = @"Timothy Burr Tim";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}