use strict;
my $str = 'Timothy Burr Tim';
my $regex = qr/(.*?)(\w+)$/p;
my $subst = '\\2 \\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";