package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#+ +\w+\.sh +#+`)
var str = `######## this_is_a_line.sh ######## `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}