$re = '/#+ +\w+\.sh +#+/';
$str = '######## this_is_a_line.sh ######## ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);