import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}-(0\\d|1[0-2])-([0-2]\\d|3[0-2])(T(([01]\\d|2[0-4]):([0-5]\\d)(:[0-5]\\d([\\.,]\\d+)?)?|([01]\\d|2[0-4])(:[0-5]\\d([\\.,]\\d+)?)?|([01]\\d|2[0-4])([\\.,]\\d+)?))?([+-]\\d\\d(:[0-5]\\d)?|Z)?$";
final String string = "2016-03-12T14:13:12.1209182451+03:00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}