#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<Error>.*?<\/Error>"
Local $sString = "<ET>read input: 1.629ms</ET>" & @CRLF & _
"<ET>There were 3 errors:" & @CRLF & _
"<Error>" & @CRLF & _
" <ErrorId>AllConditionsTrue</ErrorId>" & @CRLF & _
" <MetaData>" & @CRLF & _
" <Entry>" & @CRLF & _
" <Key>Balance Due</Key>" & @CRLF & _
" <Value>1500.99</Value>" & @CRLF & _
" </Entry>" & @CRLF & _
" </MetaData>" & @CRLF & _
"</Error>" & @CRLF & _
"" & @CRLF & _
"<Error>" & @CRLF & _
" <ErrorId>Opposite</ErrorId>" & @CRLF & _
" <MetaData>" & @CRLF & _
" <Entry>" & @CRLF & _
" <Key>Node</Key>" & @CRLF & _
" </Entry>" & @CRLF & _
" </MetaData>" & @CRLF & _
"</Error>" & @CRLF & _
"" & @CRLF & _
"<Error>" & @CRLF & _
" <ErrorId>minInclusive</ErrorId>" & @CRLF & _
" <MetaData>" & @CRLF & _
" <Entry>" & @CRLF & _
" <Key>Description</Key>" & @CRLF & _
" <Value>Wages Amount</Value>" & @CRLF & _
" </Entry>" & @CRLF & _
" </MetaData>" & @CRLF & _
"</Error>" & @CRLF & _
"" & @CRLF & _
": 0.027ms</ET>" & @CRLF & _
"<ET>convert: 319.414ms</ET>" & @CRLF & _
"<FORM id="123"/>" & @CRLF & _
"<DATA size="11920"/>" & @CRLF & _
"<ERROR code="0"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")