import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Error>.*?<\\/Error>";
final String string = "<ET>read input: 1.629ms</ET>\n"
+ "<ET>There were 3 errors:\n"
+ "<Error>\n"
+ " <ErrorId>AllConditionsTrue</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Balance Due</Key>\n"
+ " <Value>1500.99</Value>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>\n\n"
+ "<Error>\n"
+ " <ErrorId>Opposite</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Node</Key>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>\n\n"
+ "<Error>\n"
+ " <ErrorId>minInclusive</ErrorId>\n"
+ " <MetaData>\n"
+ " <Entry>\n"
+ " <Key>Description</Key>\n"
+ " <Value>Wages Amount</Value>\n"
+ " </Entry>\n"
+ " </MetaData>\n"
+ "</Error>\n\n"
+ ": 0.027ms</ET>\n"
+ "<ET>convert: 319.414ms</ET>\n"
+ "<FORM id=\"123\"/>\n"
+ "<DATA size=\"11920\"/>\n"
+ "<ERROR code=\"0\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}