package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^)(}{]|(?0))*\)|\{(?1)*\}`)
var str = `a (.)(.) b
a ({ b
a {()} b
a {()}{} b
a (()) b
a {({({({()})})})} b
a {(}) b
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}