re = /\(([^)(}{]|(?0))*\)|\{(?1)*\}/
str = 'a (.)(.) b
a ({ b
a {()} b
a {()}{} b
a (()) b
a {({({({()})})})} b
a {(}) b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end