$re = '~".*?(?<!\\\\)"(*SKIP)(*FAIL)|,~x';
$str = 'a,b,c,"d,e, g,",f
this, one, with "escaped \\"double",quotes:""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);