re = /".*?(?<!\\)"(*SKIP)(*FAIL)|,/x
str = 'a,b,c,"d,e, g,",f
this, one, with "escaped \\"double",quotes:""
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end