const regex = /^[0-9]\:[0-5][0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]\\:[0-5][0-9]$', 'gm')
const str = `0:00
1:59
2:00
9:59
00
10:55
9:60
9:99
99:99
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}