$re = '/^[0-9]\:[0-5][0-9]$/m';
$str = '0:00
1:59
2:00
9:59
00
10:55
9:60
9:99
99:99
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);