#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(sous[- ]sol)"
Local $sString = "sous-sol de xm²" & @CRLF & _
"surface en sous-sol de d'une superfice de xx m²" & @CRLF & _
"sous-sol d'une superficie de xx m²" & @CRLF & _
"surface au sous-sol de xx m²" & @CRLF & _
"surface en sous-sol d'environ xx m²" & @CRLF & _
"sous-sol: xxm²" & @CRLF & _
"xx m² : - un sous-sol" & @CRLF & _
"sous-sol xx m²" & @CRLF & _
"surface sous-sol accessible de xx m²" & @CRLF & _
"en sous-sol de xx m" & @CRLF & _
"xx m² de sous sol" & @CRLF & _
"xx m² situé au sous-sol" & @CRLF & _
"en sous-sol 42 m2" & @CRLF & _
"au sous-sol, une surface de 25 m²" & @CRLF & _
"xx m² de surface commerciale en sous-sol" & @CRLF & _
"surface commerciale en sous-sol de xx m²" & @CRLF & _
"xxm de sous-sol " & @CRLF & _
"sous-sol sur cour" & @CRLF & _
"sous-sol de plain pied de xxm" & @CRLF & _
"sous-sol propose une surface de xx m" & @CRLF & _
"sous-sol et terrasse de xx m²" & @CRLF & _
"sous-sol de plus xx m2" & @CRLF & _
"sous-sol entièrement carrelé de xx m²" & @CRLF & _
"sous sol accessible par escalier de xx m2" & @CRLF & _
"sous sol sain de xxm2" & @CRLF & _
"sous-sol avec zone de stockage de xx m²" & @CRLF & _
"sous-sol idéal pour stockage de xxm²" & @CRLF & _
"sous sol pour le stockage de xx m2" & @CRLF & _
"sous-sol avec extraction de xxm2" & @CRLF & _
"sous-sol à rénover de xx m2" & @CRLF & _
"sous sol de xxm2" & @CRLF & _
"sous-sol d'une cuisine de xx m2" & @CRLF & _
"sous-sol avec réserve et vestiaire de xx m²" & @CRLF & _
"sous-sol à usage de réserve de xx m²" & @CRLF & _
"sous-sol une cave de xxm²"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")