# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(sous[- ]sol)"
test_str = ("sous-sol de xm²\n"
"surface en sous-sol de d'une superfice de xx m²\n"
"sous-sol d'une superficie de xx m²\n"
"surface au sous-sol de xx m²\n"
"surface en sous-sol d'environ xx m²\n"
"sous-sol: xxm²\n"
"xx m² : - un sous-sol\n"
"sous-sol xx m²\n"
"surface sous-sol accessible de xx m²\n"
"en sous-sol de xx m\n"
"xx m² de sous sol\n"
"xx m² situé au sous-sol\n"
"en sous-sol 42 m2\n"
"au sous-sol, une surface de 25 m²\n"
"xx m² de surface commerciale en sous-sol\n"
"surface commerciale en sous-sol de xx m²\n"
"xxm de sous-sol \n"
"sous-sol sur cour\n"
"sous-sol de plain pied de xxm\n"
"sous-sol propose une surface de xx m\n"
"sous-sol et terrasse de xx m²\n"
"sous-sol de plus xx m2\n"
"sous-sol entièrement carrelé de xx m²\n"
"sous sol accessible par escalier de xx m2\n"
"sous sol sain de xxm2\n"
"sous-sol avec zone de stockage de xx m²\n"
"sous-sol idéal pour stockage de xxm²\n"
"sous sol pour le stockage de xx m2\n"
"sous-sol avec extraction de xxm2\n"
"sous-sol à rénover de xx m2\n"
"sous sol de xxm2\n"
"sous-sol d'une cuisine de xx m2\n"
"sous-sol avec réserve et vestiaire de xx m²\n"
"sous-sol à usage de réserve de xx m²\n"
"sous-sol une cave de xxm²")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.