#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?"
Local $sString = "Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1" & @CRLF & _
"Ctrl+PageDown" & @CRLF & _
"Ctrl+Home" & @CRLF & _
"A, B" & @CRLF & _
"Ctrl+F11, Ctrl+Home" & @CRLF & _
"Ctrl+," & @CRLF & _
"F11" & @CRLF & _
"F1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")