import re
regex = re.compile(r"(?<FirstShortcut>(?:(?:\w+\+){0,3})(?<FirstKey>\w+|.\d{0,2}))(?:,\s(?<SecondShortcut>(?:(?:\w+\+){0,3})(?<SecondKey>\w+|.\d{0,2})))?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Shift+Ctrl+Alt+C, Ctrl+Shift+Alt+F1\n"
"Ctrl+PageDown\n"
"Ctrl+Home\n"
"A, B\n"
"Ctrl+F11, Ctrl+Home\n"
"Ctrl+,\n"
"F11\n"
"F1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")