use strict;
my $str = 'test\\\\"escape\\"test\\ that
';
my $regex = qr/\\(\\*\")/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";