$re = '/\.(?=[^\s@]*@)/m';
$str = 'Input- abc.xyz@gmail.com this.is a test a.b.c@gmail.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;