re = /\.(?=[^\s@]*@)/m
str = 'Input- abc.xyz@gmail.com this.is a test a.b.c@gmail.com'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result