$re = '/(\d{11})|0x\d{1}([0-9a-fA-F]{8})\:?|\s+?/';
$str = 'ESN:0x0106C01B8    4141
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);