import re
regex = re.compile(r"(\d{11})|0x\d{1}([0-9a-fA-F]{8})\:?|\s+?")
test_str = ("ESN:0x0106C01B8 4141\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")