$re = '/\/\/(.*?)\//';
$str = 'http://stackoverflow.com/questions/8498592/extract-root-domain-name-from-string
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);