re = /\/\/(.*?)\//
str = 'http://stackoverflow.com/questions/8498592/extract-root-domain-name-from-string
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end