import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Ep )(\\d*)";
final String string = "<div class=\"anime_info\"><div class='ctdn'>Ep 7 - <span class=\"cd_day\">3</span>d <span class=\"cd_hr\">10</span>h <span class=\"cd_min\">30</span>m </div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}