const regex = /(?:Ep )(\d*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Ep )(\\d*)', '')
const str = `<div class="anime_info"><div class='ctdn'>Ep 7 - <span class="cd_day">3</span>d <span class="cd_hr">10</span>h <span class="cd_min">30</span>m </div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}