#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\$)(\d(?:,?\d)*(?:\.\d\d)?)(?:\s*-\s*\$?(\d(?:,?\d)*(?:\.\d\d)?))?\s+per\s+(?:year|month|day|hour)"
Local $sString = "ex_1 <- "starting salary: $18 per hour", "retention bonus $500", "signing bonus $150", "our nannies/babysitters choose the days they can work 8am-6pm and are in a “standby” status on their days on"" & @CRLF & _
"ex_2 <- pay: $65,000.00 - $95,623.00 per year" & @CRLF & _
"ex_3 <- "tuition assistance (100% coverage for select degrees or up to $5,250/year)", "pay: $16.25 - $16.50 per hour"" & @CRLF & _
"ex_4 <- salary: $22.00 - 30.00 per hour" & @CRLF & _
"ex_5 <- $50,000.00 per year " & @CRLF & _
"ex_6 <- $15.00 per hour " & @CRLF & _
"ex_7 <- character(0)" & @CRLF & _
"ex_8 <- "salary: $22.00 - $30.00 per hour", "pay: $47,257.00 - $49,838.00 per year")" & @CRLF & _
"" & @CRLF & _
"What I would like to extract:" & @CRLF & _
"" & @CRLF & _
"ex_1 <- 18 per hour" & @CRLF & _
"ex_2 <- 65,000.00 - 95,623.00 per year" & @CRLF & _
"ex_3 <- 16.25 - 16.50 per hour" & @CRLF & _
"ex_4 <- 22.00 - 30.00 per hour" & @CRLF & _
"ex_5 <- 50,000.00 per year" & @CRLF & _
"ex_6 <- 15 per hour" & @CRLF & _
"ex_7 <- """ & @CRLF & _
"ex_8 <- 22.00 - 30.00 per hour 47,257.00 - 49,838.00 per year " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")