# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\$)(\d(?:,?\d)*(?:\.\d\d)?)(?:\s*-\s*\$?(\d(?:,?\d)*(?:\.\d\d)?))?\s+per\s+(?:year|month|day|hour)"
test_str = ("ex_1 <- \"starting salary: $18 per hour\", \"retention bonus $500\", \"signing bonus $150\", \"our nannies/babysitters choose the days they can work 8am-6pm and are in a “standby” status on their days on\"\n"
"ex_2 <- pay: $65,000.00 - $95,623.00 per year\n"
"ex_3 <- \"tuition assistance (100% coverage for select degrees or up to $5,250/year)\", \"pay: $16.25 - $16.50 per hour\"\n"
"ex_4 <- salary: $22.00 - 30.00 per hour\n"
"ex_5 <- $50,000.00 per year \n"
"ex_6 <- $15.00 per hour \n"
"ex_7 <- character(0)\n"
"ex_8 <- \"salary: $22.00 - $30.00 per hour\", \"pay: $47,257.00 - $49,838.00 per year\")\n\n"
"What I would like to extract:\n\n"
"ex_1 <- 18 per hour\n"
"ex_2 <- 65,000.00 - 95,623.00 per year\n"
"ex_3 <- 16.25 - 16.50 per hour\n"
"ex_4 <- 22.00 - 30.00 per hour\n"
"ex_5 <- 50,000.00 per year\n"
"ex_6 <- 15 per hour\n"
"ex_7 <- \"\"\n"
"ex_8 <- 22.00 - 30.00 per hour 47,257.00 - 49,838.00 per year \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.